Tuesday, 23 April 2013

Exception: AbstractMethodError requires c3p0 upgrade

photo credit: markchadwickart
via photopin cc
I just encountered this exception:
Exception in thread "main" java.lang.AbstractMethodError: com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.setCharacterStream(ILjava/io/Reader;J)V at org.hibernate.type.descriptor.sql.ClobTypeDescriptor$4$1.doBind(ClobTypeDescriptor.java:114) at org.hibernate.type.descriptor.sql.BasicBinder.bind(BasicBinder.java:92)
It turns out that upgrading c3p0 does the trick (from 0.9.1.2 to 0.9.2.1):

        <dependency>
            <groupId>com.mchange</groupId>
            <artifactId>c3p0</artifactId>
            <version>0.9.2.1</version>
        </dependency>

0 comments:

Post a Comment